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1. Przechowywanie i ochrona kluczy.  

 Informację o tym gdzie są przechowywane klucze: prywatny oraz publiczny można 
uzyskać w następujący sposób: 

• Uruchomić program PGPkeys: Start->Programy->PGP->PGPkeys. Wynikiem 
wykonania tej czynności będzie pojawienie się okna podobnego do okna przedstawio-
nego na rysunku 1. 

• Wyświetlić okno opcji programu PGPkeys: Edit->Options. Wynikiem wykona-
nia tej czynności będzie pojawienie się okna podobnego do okna przedstawionego na 
rysunku 2.  

• Wybrać zakładkę Files. Wynikiem wykonania tej czynności będzie pojawienie się 
w oknie PGP Options informacji dotyczących miejsca przechowywania kluczy. (Ry-
sunek 3)  

 

 

 
W oknie przedstawionym na rysunku 3 są przedstawione informacje dotyczące lokalizacji 
plików, w których są zapisane klucze. Okno zawiera trzy grupy informacji: 
• PGP Keyring Files 

o Public Keyring File – okienko edycyjne zawierające lokalizację i nazwę 
pliku, w którym są przechowywane informacje o kluczu publicznym. Jeżeli 
użytkownik zamierza zmienić nazwę pliku lub jego lokalizację powinien 
uaktualnić te informacje w tym okienku edycyjnym. Aby zmienić informa-
cje dotyczące lokalizacji klucza publicznego należy wprowadzić ścieżkę 
do pliku zawierającego informacje o kluczu publicznym lub zlokalizować 
ten plik poprzez kliknięcie przycisku Browse. 

o Private Keyring File – okienko edycyjne zawierające lokalizację i nazwę 
pliku, w którym są przechowywane informacje o kluczu prywatnym. Jeżeli 
użytkownik zamierza zmienić nazwę pliku lub jego lokalizację powinien 
uaktualnić te informacje w tym okienku edycyjnym. Niektórzy użytkowni-
cy dla lepszej ochrony swego pliku z informacją o kluczu prywatnym prze-
chowują ten plik na dyskietce, której używają wtedy, gdy zachodzi potrze-
ba użycia podpisu (sign) lub odszyfrowania wiadomości. Ta lokalizacja 
jest również używana do automatycznego składowania kopii klucza pu-
blicznego. Aby zmienić informacje dotyczące lokalizacji klucza prywatne-
go należy wprowadzić ścieżkę do pliku zawierającego informację o kluczu 

Rysunek 1 Okno główne programu PGKkeys 

Edit->Options 
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prywatnym lub zlokalizować ten plik poprzez kliknięcie przycisku Brow-
se. 

• PGPnet Keying Files 
• Random Seed file 
W celu dokładnego ustawienia pozostałych opcji w tym oknie należy się skontaktować z 
administratorem PGP.  
Pliki zawierające informacje o kluczu prywatnym i publicznym należy chronić przed nie-
powołanym dostępem. Należy też utworzyć kopie zapasowe tych plików, aby w ten spo-
sób zapobiec utracie kluczy w wyniku awarii dysku itp.   

 

 

 

 
 

Rysunek 2 Okno główne opcji programu PGPkeys 
 

Zakładka Files 
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Rysunek 3 Okno zawierające informacje o położeniu kluczy 
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2. Udostępnianie własnego klucza publicznego innym użytkowni-
kom. 

 
Aby użytkownik mógł odbierać zaszyfrowane wiadomości od innych użytkowników musi im 
udostępnić swój klucz publiczny. Można to zrobić na kilka sposobów: 
1) poprzez wysłanie swego klucza publicznego na serwerze kluczy; 
2) poprzez dołączenie swego klucza publicznego do poczty elektronicznej; 
3) poprzez wyeksportowanie swego klucza publicznego lub skopiowanie go do pliku i dołą-

czenie do poczty. 
 
 
1) Aby wysłać własny klucz publiczny  na serwer kluczy należy postępować według po-

niższych wskazówek: 
• Podłączyć komputer do internetu; 
• Uruchomić program PGPkeys: Start->Programy->PGP->PGPkeys; 
• W oknie edycyjnym programu podświetlić zapis reprezentujący własny klucz publicz-

ny, który użytkownik chce umieścić na serwerze kluczy. 

 

 
• Z menu głównym programu PGPkeys wybrać pole Server, a w podmenu pole Send 

To, czyli Server->Sent To->wybrać_server_kluczy. Wybranie serwera 
kluczy spowoduje wyświetlenie się okna przedstawionego na rysunku 4; 

• Jeżeli klucz został pomyślnie dodany to wyświetli się okno informujące użytkownika 
o pomyślnym zakończeniu operacji. Klucz publiczny użytkownika jest udostępniony 
na serwerze kluczy (Rysunek 6). 

 

Rysunek 4 Okno zawierające informacje o położeniu kluczy 

Menu główne programu PGPkeys i pole Server 

Podświetlony zapis
klucza do wysłania
na serwer 
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2) Aby wysłać swój klucz publiczny do innego użytkownika za pomocą poczty elektro-
nicznej należy postępować według poniższych wskazówek: 
• Uruchomić program PGPkeys: Start->Programy->PGP->PGPkeys; 
• W oknie edycyjnym zaznaczyć zapis dotyczący własnej pary kluczy; 
• Wybrać pole Copy z menu, które się rozwinie po wciśnięciu pola Edit z menu 

głównego programu PGPkeys: Edit->Copy. 

 

 

Rysunek 5 Okno informujące o tym, że trwa proces połączenia   
z serwerem kluczy 

Rysunek 6 Okno informujące o umieszczeniu klucza na serwerze kluczy 
 

Rysunek 7 Okno PGPkeys w przypadku kopiowania klucza 

Podświetlony zapis klucza do wy-
słania w poczcie elektronicznej 

Menu Edit. Po rozwinięciu
ukaże się m.in. pole Copy 
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• Uruchomić program Outlook Express, wpisać adresata i temat wiadomości. Następnie 
umieścić kursor w miejscu wpisywania treści wiadomości i wybrać pole Wklej z 
Menu Edycja programu pocztowego: Edycja->Wklej. 

• Wskazane jest oznaczenie wiadomości. Pozwoli to adresatowi zweryfikować nadawcę 
– wcisnąć ikonę Sign(PGP) przed wysłaniem wiadomości.(Rysunek 8) 

• Wysłać wiadomość. Jeżeli oznaczono wiadomość podać hasło. (Rysunek 9) 

 

 

Można też przeciągnąć zaznaczony opis klucza przedstawiony na rysunku 7 do okna przed-
stawionego na rysunku 8. Wtedy klucz zostanie wysłany w postaci załącznika. Inne czynności 
przeprowadzić analogicznie. Wcześniej należy wyeksportować klucz publiczny do pliku, tzn. 

Rysunek 8 Okno Outlook Express w przypadku wysyłania klucza publicznego 

Rysunek 9 Okno do wpisania hasła dla podanego klucza 

Menu Edycja. Po rozwinięciu
ukaże się m.in. pole Wklej 

Dla oznaczenie wiadomości
wcisnąć ikonę Sign(PGP) 
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wybrać klucz i za pomocą  menu Keys przejść do pola Export: Keys->Export(patrz 
podpunkt 3) Podać nazwę pliku. Czynności do wykonania: 

• Uruchomić program PGPkeys; 
• Uruchomić Outlook Express i utworzyć nową wiadomość; 
• Rozmieścić oba okna na ekranie monitora, tak aby były widoczne; 
• W oknie PGPkeys: 

o Zaznaczyć klucz do wysłania; 
o Wskazać ten klucz kursorem myszki, nacisnąć lewy przycisk myszy; 
o Nie zwalniając lewego przycisku myszki przeciągnąć klucz do okna Outlook 

Express; 
o W okienku edycyjnym dla załączników pojawi się napis postaci nazwa.asc 

(Rysunek 10); 
• Oznaczyć wiadomość; 
• Wysłać. Podać hasło przypisane do klucza (Rysunki: 8, 9); 

 

 

 
 

3) Aby wyeksportować lub skopiować do pliku klucz publiczny i wysłać go w postaci 
załącznika do poczty należy postępować według poniższych wskazówek: 

• Uruchomić program PGPkeys: Start->Programy->PGP->PGPkeys; 
• Zaznaczyć zapis reprezentujący klucz umieszczony w oknie programu PGPkeys, a 

następnie wybrać pole Export z menu Keys Keys->Export ; 
• Podać lokalizację i zapisać klucz przy pomocy okna dialogowego, które się pojawi 

po wykonaniu kroku poprzedniego. 
• Wysłać klucz publiczny w postaci załącznika do poczty.  

Rysunek 10 Okno Outlook Express przy wysyłania klucza po przeciągnięciu go 
z okna PGPkeys 

Klucz w postaci załącznika Wcisnąć ikonę Sign(PGP) 
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Istnieje też możliwość skopiowania klucza do pliku tekstowego. W tym celu należy: 

• Skopiować klucz (Rysunek 7); 
• Utworzyć plik tekstowy; 
• Wkleić skopiowany klucz do pliku tekstowego: 

o Ustawić kursor w oknie utworzonego pliku tekstowego; 
o Wcisnąć kombinację Edycja->Wklej w oknie edytora utworzonego pliku; 
o Zapisać plik z rozszerzeniem *.txt. 

Tak zapisany klucz może być wysłany jako plik załączony do wiadomości pocztowej. 

 

 

 

 

 

 

 

Rysunek 11 Okno PGPkeys z opisem do wyeksportowania klucza do pliku 

Wybrać pole Keys. Po rozwinięciu
się menu wybrać pole Export 

Zaznaczyć zapis klucza
do zapisania w pliku 
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3. Pobieranie kluczy publicznych innych użytkowników. 

W celu wymiany zaszyfrowanych informacji pomiędzy użytkownikami, konieczne jest posia-
danie kluczy publicznych adresatów przesyłek pocztowych.  Klucz publiczny innego użyt-
kownika można uzyskać poprzez: 
1) pobranie klucza danego użytkownika z serwera kluczy; 
2) pobranie klucza z wiadomości pocztowej przysłanej przez użytkownika udostępniającego 

klucz publiczny; 
3) pobranie klucza z pliku udostępnionego przez użytkownika udostępniającego klucz pu-

bliczny. 
 
1) Aby pobrać klucz publiczny danego użytkownika z serwera kluczy należy postępo-

wać według poniższych wskazówek: 
• Uruchomić program PGPkeys : Start->Programy->PGP->PGPkeys; 
• Kliknąć na  pole Search z menu Server: Server->Search (Rysunek 12);  

 

 
• Po otwarciu okna dialogowego Search w polu Search for Keys On wy-

brać lokalizację lub serwer, na którym znajduje się klucz publiczny użytkownika. 
(Rysunek 13). 

• Wprowadzić kryteria potrzebne do określenia klucza publicznego użytkownika. 
Jeżeli klucz został znaleziony można go przenieść do okna PGPkeys, tzn. Zazna-
czyć kursorem myszki konkretny opis klucza, nacisnąć lewy przycisk myszki i nie 
zwalniając przycisku z lewego przycisku myszki przeciągnąć kursor myszy do 
okna PGPkeys.(Rysunki 13,12); 

• Przeniesiony klucz pojawi się w oknie PGPkeys. 
 
 
 
 
 
 
 
 

Rysunek 12 Okno PGPkeys i opis do wyboru serwera w celu pobrania klucza 

Z menu Server wybrać pole Search 
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2) Aby pobrać klucz z wiadomości tekstowej należy postępować według poniższych 
wskazówek: 
• Skopiować z okna Outlook Express obszar, który przedstawia klucz publiczny: 

o Zaznaczyć myszką obszar klucza; 
o W menu Edycja Kliknąć na pole Kopiuj: Edycja->Kopiuj; 
o Wyjść z programu Outlook Express; (Rysunek 15) 

 
 
 
 
 

Rysunek 13 Okno do wyszukiwania klucza publicznego danego użytkownika 

Rysunek 14 PGPkeys po dodaniu klucza publicznego użytkownika Kowalskiego 

Okno do wyboru
serwera kluczy 

Pola kryteriów 
wyszukiwania 

Poszukiwany 
klucz publiczny 

Dodany klucz 
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• Uruchomić program PGPkeys: Start->Programy->PGP->PGPkeys 
• Kliknąć na pole Paste z menu Edit: Edit -> Paste. 

 

 

 

 
• Po ukazaniu się okna Select Key(s) Kliknąć  na klucz i wcisnąć przycisk Im-

port(Rysunek 17); 
 

Rysunek 15 Sposób skopiowania zawartości klucza publicznego z programu pocztowego 

Rysunek 16 Elementy okna PGPkeys istotne przy dodawaniu klucza 

Z menu Edycja wybrać Kopiuj 

Wybrać Paste z menu Edit 
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• Nowy klucz pojawi się w oknie programu PGPkeys.  

 
 
3) Aby dołączyć klucz publiczny z pliku należy postępować według poniższych wskazó-

wek: 
• Uruchomić program PGPkeys: Start->Programy->PGP->PGPkeys; 
• Otworzyć plik zawierający klucz publiczny(Rysunek 18); 
• Zaznaczyć i skopiować blok tekstu reprezentujący klucz publiczny (korzystając z me-

nu Edycja Notatnika: Edycja->Zaznacz wszystko, Edycja->Kopiuj); 
• Użyć pola Paste z menu Edit programu PGPkeys: Edit->Paste. Spowoduje 

to ukazanie się okna jak na rysunku 16. 
• Po ukazaniu się okna Select Key(s) wybrać klucz i wcisnąć przycisk Im-

port(Rysunek 17); 
• Nowy klucz pojawi się w oknie programu PGPkeys.  

Można też przeciągnąć plik tekstowy z kluczem do okna PGPkeys. Dalej postępować tak 
jak w momencie pojawienia się okna przedstawionego na rysunku 17. 

 
 

Rysunek 17 Okno służące do importowania klucza  
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Rysunek 18 Klucz publiczny w pliku tekstowym 
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4. Wysyłanie zaszyfrowanych wiadomości pocztowych 

Aby wysłać zaszyfrowaną wiadomość do wybranego użytkownika przy użyciu programu 
Outlook Express należy postępować według poniższych wskazówek: 

• Pobrać klucz publiczny adresata wiadomości (sposób pobierania klucza publicznego 
danego użytkownika opisano w rozdziale 3 instrukcji); 

• Uruchomić program Outlook Express; 
• Wypełnić pola nadawcy, adresata, tematu wiadomości; 
• Wpisać wiadomość; 
• Wcisnąć ikony Encrypt (PGP) – w celu zaszyfrowania wiadomości i ikonę Sign 

(PGP) – w celu podpisania wiadomości.(Rysunek 19) 

 

 

 
• Wysłać wiadomość. Po tej czynności ukaże się okno w którym tak jak na rysunku 20. 

Należy wybrać jakimi kluczami publicznymi zakodować wiadomość; 

Rysunek 19 Sposób wysłania zakodowanej wiadomości 

Wcisnąć ikonę Encrypt
(PGP) – w celu zaszyfrowania
wiadomości 

Wcisnąć  Sign (PGP) –
w celu podpisania wia-
domości. 

Wysłać 
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• Teraz trzeba podać hasło (Rysunek 21). 
 

 

Rysunek 20 Wybór kluczy publicznych adresatów poczty 

Rysunek 21 Okno do wpisania hasła 

Tu należy umieścić klucze,
tych użytkowników, do któ-
rych planujemy wysłać pocz-
tę i swój klucz. 

Tu jest lista wszystkich kluczy
publicznych jakie posiada
użytkownik 
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• Następnie wiadomość zostanie zaszyfrowana i wysłana. Rysunek 22 przedstawia za-
szyfrowaną wiadomość po stronie odbiorcy. 

 
 

 

 
 

 

 

 

 

 

 

 

 

 

Rysunek 22 Zaszyfrowana wiadomość po stronie adresata 
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5. Odczytywanie odebranych zaszyfrowanych wiadomości poczto-
wych 

Aby odszyfrować zaszyfrowaną wiadomość pocztową należy postępować według poniższych 
wskazówek: 

• Uruchomić program Outlook Express w oknie „Skrzynka odbiorcza”; 
• Zaznaczyć wiadomość do odszyfrowania i dwukrotnie kliknąć lewym przyciskiem 

myszki (Rysunek 23). 

 
 

 
 
• W oknie które się pojawi wcisnąć ikony Decrypt PGP message – w celu odszy-

frowania (Rysunek 24); 
• Gdy pokaże się okno jak na rysunku 25 – podać hasło; 

 

 

Rysunek 23 Widok zaszyfrowanej wiadomości w oknie Skrzynka odbiorcza Outlook Express 

Zaznaczyć i dwukrotnie, szybko kliknąć lewym przyciskiem myszki 
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Rysunek 24 Okno Outlook Express do odszyfrowania wiadomości 

Rysunek 25 Okno do wpisania hasła 

Wcisnąć ikonę Decrypt PGP message
w celu odszyfrowania wiadomości 
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• Okno z odszyfrowaną wiadomością wygląda jak na rysunku 26: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Rysunek 26 Okno z rozszyfrowaną wiadomością 
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6. Szyfrowanie plików 

Aby zaszyfrować plik należy postępować według poniższych wskazówek: 
• Uruchomić Explorator Windows NT: Start->Programy->Explorator Win-

dows NT.  Wskazać plik do zaszyfrowania (Rysunek 27); 
• Wskazać kursorem myszki plik i kliknąć prawym przyciskiem myszki. Pojawi się me-

nu. Z menu wybrać PGP->Encrypt lub, PGP->Encrypt&Sign 
 

 
 

 
 

• Pokaże się okno jak na rysunku 28. Wybrać klucze publiczne, którymi użytkownik 
chce zaszyfrować plik. 

• Podać hasło w oknie jak na rysunku 25. 
• Zaszyfrowany plik jest umieszczony w bieżącym katalogu; (Rysunek 29) 

 

 

 

 

 

 

 

Rysunek 27 Okno Eksploratora Windows NT, z wybranym do zaszyfrowania plikiem 

Wskazać plik do zaszyfrowania, kliknąć prawym przyciskiem
myszki. Pojawi się menu. Z menu wybrać PGP->Encrypt lub
PGP->Encrypt&Sign 
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Rysunek 28 Okno do wyboru osób uprawnionych do rozszyfrowania pliku 

Rysunek 29 Widok zaszyfrowanego pliku 

Z tego okna wybrać klucze
osób, które będą mogły rozszy-
frować plik ...... 

...i przesunąć je do tego
okna 

Zaszyfrowany plik 
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7. Odczytywanie zaszyfrowanych plików 

Aby odczytać plik zaszyfrowany kluczem publicznym danego użytkownika należy postępo-
wać według poniższych wskazówek: 

• Uruchomić Explorator Windows NT: Start->Programy->Explorator Win-
dows NT.  Wskazać plik do rozszyfrowania.(Rysunek 29); 

• Wskazać kursorem myszki plik i kliknąć prawym przyciskiem myszki. Pojawi się me-
nu. Z menu wybrać PGP->Descrypt&Verify  

• Jeżeli się okno jak na rysunku 30 podać hasło; 
 

 

 

• Rozszyfrowany plik znajduje się w bieżącym katalogu.(Rysunek 31) 

 

 

Rysunek 30 Okno: Podać hasło 

Rysunek 31 Okno pokazujące lokalizację rozkodowanego pliku 

Rozszyfrowany plik 
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8. Szyfrowanie tekstu z wybranego okna lub ze schowka 

W celu zaszyfrowania tekstu umieszczonego w wybranym oknie np. w Notatniku należy po-
stępować według poniższych wskazówek: 

• Wskazać na okno edytora np. Notatnika tak, aby było aktywne; 
 

 
 

 
 

 
• Kliknąć dowolnym klawiszem myszki na ikonie agenta PGP umieszczoną w prawym 

dolnym rogu ekranu w pasku zadań na ikonie przypominającej żółtą kłódkę przyłączo-
ną do drutu (Rysunek 33)  

 

 

 

 

Rysunek 32 Okno notatnika z tekstem do zaszyfrowania 

Rysunek 33 Ikona PGP agenta na pasku zadań  

Ikona agenta PGP  
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• Po rozwinięcie się paska menu wybrać: Current Window->Encrytp lub Cur-
rent Window->Encrytp&Sign 

• W następnym oknie przedstawionym na rysunku 28 wskazać klucze uprawnione do 
odszyfrowania tego tekstu; 

• Padać hasło w oknie przedstawionym na rysunku 30. 
• Zakodowany tekst przedstawiono na rysunku 34: 

 

 

 
Jeżeli użytkownik chce przenieść tekst z jednego dokumentu do drugiego posługuje się 
schowkiem (Clipboard). PGP daje możliwość zaszyfrowania tekstu pochodzącego ze schow-
ka. W celu zaszyfrowania tekstu ze schowka należy postępować według poniższych wskazó-
wek: 

• Skopiować tekst do schowka: tzn zaznaczyć tekst myszką i korzystając z menu Edy-
cja->Kopiuj lub Edit->Paste skopiować tekst (Rysunek 35). 

• Kliknąć dowolnym klawiszem myszki na ikonie PGP agenta umieszczoną w prawym 
dolnym rogu ekranu w pasku zadań na ikonie przypominającej żółtą kłódkę przyłączo-
ną do drutu (Rysunek 33)  

• Po rozwinięcie się paska menu wybrać: Clipboard->Encrytp lub Clipboard-
>Encrytp&Sign 

• W następnym oknie przedstawionym na rysunku 28 wskazać klucze uprawnione do 
odszyfrowania tego tekstu; 

• Padać hasło w oknie przedstawionym na rysunku 30. 
 
 
 

Rysunek 34 Okno edytora Notatnik z zaszyfrowanym tekstem 
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Zaszyfrowany tekst można wkleić np. do bieżącego dokumentu. Z menu Edycja należy 
kliknąć na pole Wklej: Edycja->Wklej. Oto zaszyfrowany tekst z okna przedstawione-
go na rysunku 35, wklejony ze schowka.  
 
-----BEGIN PGP MESSAGE----- 
Version: PGP 7.0 
 
qANQR1DBwU4DZ3odd9u3DEMQB/9vB2PsXPKSkk0hWvo+A1wqkhJN+w1L8N2ANrtu 
xzBF2tlNNh3HDBja+sLNeFKOotbmM0swOORg1r0+LJQ76kq1ZF/HR0cjaehe3E4Z 
I3h/0NVWro7+HYweDwXRfdz2DtMDTdybP4iCsm/2wUillOyurHL5yswS0MqyuYqX 
MNMHT5updGdfXv6JZwyS5pqYnmTuqaCF7VexuV0DfsYxOyOwdoEUg6P222O61joL 
qlZ13VgnOrjvOgBiUN/vPjRjz7Re0DZ6yVNRHmw8qGy00lvV470TEdNzEqnF+8uO 
V/91/GDyg13XVOF/NzBqr++5kAO68agpwRE3Adj66uSFkqvuCAC32WereA644w6N 
vE0Ci9GvDlom7C3ghC4sQ14b61jU6bFqPIZjq+vv9ocBfAcJuTBcOcXa9bHkJnP0 
H5tRJmkoC9M6q77PQ8uuSMmhAig9vjhhOcT38DispZjkrUvYl92kOxwjMH7aedt2 
emiyJPl7GVOf/EZrdsYrVK2W8qG9sFVSfUcLvB4T/LdBtv5qhZg6sBUcLAC0PS/5 
fdaOwykO3lmt12/uzrCkcOO7pAes6gpESpKPS0scO979hG4kVkO8Un9S0j/WIYkM 
3Wm1kA3xIjtMFJ8f+5+BYMHxL26HfWeFgCn9PDJHqLIGldsqgqVxSV8pyniOtaer 
IKu/MSsrwcFOA6KviK/eGc2GEAgA4kkjCJebdAp2+zjlDHBz290KvopjqqyKGprP 
vUjE9ZD0rNjMFcbuODu84+OrjpAm5lGILkaBe3ONfRGY2mrkwQxGlTr+rldO/7b9 

Rysunek 35 Sposób kopiowania tekstu do schowka 

Zaznaczyć tekst myszką i korzystając z menu Edycja->Kopiuj lub 
Edit->Paste skopiować tekst 
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6QxL4+jB/BcYFjeLMgovZR8qXfnifIvnF30aPDmKJx1kC+nwqwv9Z3K6KpK2OlVk 
v69T7F+U11aUjgp6EI4N5A7JjkeHzCv99Fd26ComNHsXZLBJoqo2TSjhs/06nPm0 
MGgHdZnPSpQ7WOtsgou32w0prZGOHeE6IJ3L5JgkR1bMo9vsXohVI9Lteku3/fuy 
k/CoJptgdyDnYU7wXZoH31svPBU306YCbbCuVAUqJvtltJGDUAf/eLr6wIinZ0Jp 
YtP++bNTWbx31cmsnFsB3kYUW9ELYiFPl0fj2EStdEX6xsAWcU+cgxeaqtDfEpvq 
evhl3cItU0cHPaaoZf2RzXA6FNJd3Og4qhdSh2WqMJWyXWkHpyf/0FtDXDPGvBqS 
HkUeB46gA6y1oUXpxd8VmXYnAfBt1278yU6TZKD7WuXfdSLmbBqE/ZdGKq6WqOvM 
PSLddMBEMRoalLkoPygnzfAwqLGEehANPZQSZufo5DdmV/qSFAMChz7ZKlzH0RhC 
zQlP1DhirR/7GzB5+/T+IldNtdjZ09v7RqEPU6ynsR9RKi4miStzjU1fJCt7oN+D 
/OeAPWrUr8lvFNBtp5tdBIsLN9jHimpRpwz4Lg8u2H496WygBcdcye1GtqvsRBGd 
dkxo1kBomvLJd3+jScsVisHaPg0K19dgs9ydkeXwFxFk4AMw6iBzUcOdtZgeLn40 
CSj1Y3BJvXLpWgFQ1LXK7A3yPdmMxnLu 
=iOdg 
-----END PGP MESSAGE----- 
 

 

 
Aby podejrzeć zawartość schowka należy kliknąć ikonę agenta PGP (Rysunek 33) i przejść 
do pola Cipboard->Edit. Okno schowka PGP po wklejeniu poniższego tekstu przedsta-
wiono na rysunku 36. 
W celu usunięcia zawartości schowka należy kliknąć ikonę agenta PGP (Rysunek  
33) i przejść do pola Cipboard->Empty.  
 
 
 
 
 

Rysunek 36 Schowek PGP z zaszyfrowanym tekstem: „Ala ma kota” 
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Rysunek 37 Podpis wiadomości pocztowej 

Wciśnięcie ikony Sign (PGP) przed wysłaniem wiadomo-
ści spowoduje dołączenie sygnatury identyfikującej
nadawcę wiadomości 
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9. Podpisywanie tekstu 

Aby podpisać poniższy tekst:  
 
Tekst do podpisania  
 
Należy: 

• Skopiować tekst do schowka: tzn zaznaczyć tekst myszką i korzystając z menu Edy-
cja->Kopiuj lub Edit->Paste skopiować tekst (Rysunek 35). 

• Kliknąć dowolnym klawiszem myszki na ikonie agenta PGP umieszczoną w prawym 
dolnym rogu ekranu w pasku zadań na ikonie przypominającej żółtą kłódkę przyłączo-
ną do drutu (Rysunek 33).  

• Po rozwinięcie się paska menu wybrać: Clipboard->Sign. 
• Padać hasło w oknie przedstawionym na rysunku 30. 

 
Poniżej przedstawiono podpisany tekst: Tekst do podpisania 
 
-----BEGIN PGP SIGNED MESSAGE----- 
Hash: SHA1 
 
Tekst do podpisania  
 
-----BEGIN PGP SIGNATURE----- 
Version: PGP 7.0 
 
iQA/AwUBOfA3FzA10c0dDVTfEQLPwQCfejTSo5BuE4ddJIcGYJY+BClkTC0An2Y+ 
Oh7HNjV5LezZNi1lTflYUVGo 
=xJx6 
-----END PGP SIGNATURE----- 
 

Podpisanie wiadomości do wysłania pocztą polega na wciśnięci ikony Sign (PGP) w menu 
ikon programu Outlook Ekspress. Rysunek 37. 
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10. Odczytanie zaszyfrowanego tekstu z okna lub ze schowka 

W celu odczytania zaszyfrowanego tekstu z okna należy postępować według poniższych 
wskazówek: 

• Przejść do okna z zaszyfrowanym tekstem – uaktywnić okno z zaszyfrowanym tek-
stem. 

 

 

 

 

• Kliknąć dowolnym klawiszem myszki na ikonie agenta PGP (umieszczonej w prawym 
dolnym rogu ekranu w pasku zadań) na ikonie przypominającej żółtą kłódkę przyłą-
czoną do drutu (Rysunek 33); 

• Po rozwinięciu paska menu wybrać: CurrentWindow->Decrytp&Verify; 
• Padać hasło w oknie przedstawionym na rysunku 30; 
• Rozkodowany tekst ukaże się w edytorze PGP; (Rysunek 39) 

 

Rysunek 38 Okno z zaszyfrowanym tekstem 
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Tekst z okna przedstawionego na rysunku 38 można skopiować do schowka (wcisnąć przy-
cisk Copy to Clipboard) i wkleić go do dowolnego pliku. 
 
 Jeżeli zaszyfrowany tekst znajduje się w schowku (np. zaszyfrowany tekst: „Ala ma 
kota” z rozdziału 8), to w celu odczytania tego zaszyfrowanego tekstu należy postępować we-
dług poniższych wskazówek: 

• Kliknąć dowolnym klawiszem myszki na ikonie agenta PGP umieszczoną w prawym 
dolnym rogu ekranu w pasku zadań na ikonie przypominającej żółtą kłódkę przyłączo-
ną do drutu (Rysunek 33);  

• Po rozwinięcie się paska menu wybrać: Clipboard->Decrypt&Verify; 
• Padać hasło w oknie przedstawionym na rysunku 30; 
• Pokaże się okno podobne przedstawione na rysunku 40; 
• Tekst można skopiować do schowka i wkleić np. poniżej: 

 
*** PGP Signature Status: good 
*** Signer: Jan Nowak<orionous@poczta.onet.pll> 
*** Signed: 00-10-20 12:39:28 
*** Verified: 00-10-20 13:44:26 
*** BEGIN PGP DECRYPTED/VERIFIED MESSAGE *** 
 
Ala ma kota 
 
 
*** END PGP DECRYPTED/VERIFIED MESSAGE *** 
 

Rysunek 39 Rozszyfrowany tekst z rysunku 38 
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Rysunek 40 Okno z rozszyfrowanym tekstem z rysunku 35 
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11. Generowanie pary kluczy 

UWAGA !  
 Klucz mógł zostać wygenerowany w trakcie instalacji pakietu PGP.  
 
 
  W celu wygenerowania nowej pary kluczy należy: 

• Kliknąć ikonę „Launch PGPkeys” umieszczoną w pasku narzędzi okna głównego 
Outlook Express przedstawionego na rysunku 41. Przykładowe okno, które się wy-
świetli na skutek kliknięcia ikony „Launch PGPkeys”, przedstawiono na rysunku 
42. 

 
 
 
 
 
 
 
 

Ikona  
„Launch PGPkeys”  

Rysunek 41  Okno główne Outlook Express po zainstalowaniu pakietu PGP 
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• Z menu tekstowego okna przedstawionego na rysunku 42 za pomocą myszy Klik-

nąć na pole: Keys. Po rozwinięciu podmenu należy wybrać pole: New 
Key...Ctrl+N. Ten sam efekt można uzyskać poprzez użycie klawiszy szyb-
kiego dostępu (należy na klawiaturze jednocześnie nacisnąć klawisze: Ctrl i 
N). Działanie to spowoduje, że uruchomi się program, który przeprowadzi użyt-
kownika przez proces generacji kluczy. Okno tego programu zostało przedstawio-
ne na rysunku 43. 

• W oknie z rysunku 43 należy kliknąć przycisk Expert. Pojawi się okno przed-
stawione na rysunku 44. W tym oknie należy wypełnić okienka edycyjne w sposób 
następujący: 

o Full name – wpisać własne imię i nazwisko; 
o Email address – wpisać własny adres skrzynki pocztowej; 
o Key type – wybrać jeden z trzech dostępnych algorytmów kodowania: 

!"Diffie – Hellman/DDS; 
!"RSA (obsługiwany tylko przez wersję 7.0 PGP);  
!"RSA – Legacy (obsługiwany przez wcześniejsze wersje PGP); 

Rysunek 42 Okno PGPkeys 
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Rysunek 43 Okno programu służącego do generacji klucza 

Rysunek 44 Okno programu generowania klucza po wciśnięciu przycisku 
„Expert” 
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!"Key size – długość w bajtach bloku z zakodowaną wiadomością; 
!"Key expiration – okres ważności klucza; 

 
• Po wciśnięciu klawisza Dalej pojawia się okno przedstawione na rysunku 45. 

W okienku edycyjnym Passphrase należy wpisać ciąg znaków złożonych z liter, cyfr 
itp. i zapamiętać. W okienku edycyjnym Confirmation należy jeszcze raz wpisać ha-
sło dokładnie takie jak w poprzednim okienku. Wpisany ciąg stanowi hasło, które bę-
dzie potrzebne do kodowania i rozkodowywania wiadomości. 

 

 
• Po wpisaniu i potwierdzeniu hasła wcisnąć przycisk Dalej. Po wykonaniu tych 

czynności i pod warunkiem poprawnego wpisania hasłu w dwóch okienkach edycyj-
nych nastąpi proces generowania pary kluczy. Okno jakie użytkownik zobaczy w tym 
czasie przedstawiono na rysunku 46. 

• Po zakończeniu generowania pary kluczy wcisnąć przycisk Dalej, który będzie już 
dostępny. 

• Ukaże się okno informujące o zakończeniu generacji pary kluczy. Należy wcisnąć 
przycisk Zakończ. (Rysunek 47) 

 Rysunek 45 Okno służące do wpisania ciągu znaków stanowiącego hasło 

Odznaczenie tego checbox’u spowoduje pojawienie się 
ciągu znaków stanowiącego hasło. Nie należy ujawniać 
hasła i pokazywać go w obecności innych osób 
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• Wygenerowana para kluczy jest przedstawiona w oknie PGPkeys, które ukaże się po 

wciśnięciu klawisza Zakończ w oknie przedstawionym na rysunku 47. Rysunek 48 
przedstawia okno PGPkeys po dodaniu pary kluczy Jana Nowaka. 

Rysunek 46 Okno pokazujące fakt generowania klucza  

Rysunek 47 Okno informujące o  wygenerowaniu pary kluczy 
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Rysunek 48 Okno PGPkeys po dodaniu klucza 

Para kluczy Jana Nowaka 
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12. Spis rysunków, wyjaśnienie niektórych zapisów 

 
RYSUNEK 1 OKNO GŁÓWNE PROGRAMU PGKKEYS.....................................................................3 

RYSUNEK 2 OKNO GŁÓWNE OPCJI PROGRAMU PGPKEYS ............................................................4 

RYSUNEK 3 OKNO ZAWIERAJĄCE INFORMACJE O POŁOŻENIU KLUCZY ........................................5 

RYSUNEK 5 OKNO INFORMUJĄCE O TYM, ŻE TRWA PROCES POŁĄCZENIA   Z SERWEREM KLUCZY7 

RYSUNEK 6 OKNO INFORMUJĄCE O UMIESZCZENIU KLUCZA NA SERWERZE KLUCZY...................7 

RYSUNEK 7 OKNO PGPKEYS W PRZYPADKU KOPIOWANIA KLUCZA ............................................7 

RYSUNEK 8 OKNO OUTLOOK EXPRESS W PRZYPADKU WYSYŁANIA KLUCZA PUBLICZNEGO........8 

RYSUNEK 9 OKNO DO WPISANIA HASŁA DLA PODANEGO KLUCZA ...............................................8 

RYSUNEK 10 OKNO OUTLOOK EXPRESS PRZY WYSYŁANIA KLUCZA PO PRZECIĄGNIĘCIU GO 

Z OKNA PGPKEYS................................................................................................................9 

RYSUNEK 11 OKNO PGPKEYS Z OPISEM DO WYEKSPORTOWANIA KLUCZA DO PLIKU................10 

RYSUNEK 12 OKNO PGPKEYS I OPIS DO WYBORU SERWERA W CELU POBRANIA KLUCZA..........11 

RYSUNEK 13 OKNO DO WYSZUKIWANIA KLUCZA PUBLICZNEGO DANEGO UŻYTKOWNIKA ........12 

RYSUNEK 14 PGPKEYS PO DODANIU KLUCZA PUBLICZNEGO PANA KOWALSKIEGO ..................12 

RYSUNEK 15 SPOSÓB SKOPIOWANIA ZAWARTOŚCI KLUCZA PUBLICZNEGO Z PROGRAMU 

POCZTOWEGO ....................................................................................................................13 

RYSUNEK 16 ELEMENTY OKNA PGPKEYS ISTOTNE PRZY DODAWANIU KLUCZA........................13 

RYSUNEK 17 OKNO SŁUŻĄCE DO IMPORTOWANIA KLUCZA .......................................................14 

RYSUNEK 18 KLUCZ PUBLICZNY W PLIKU TEKSTOWYM ............................................................15 

RYSUNEK 19 SPOSÓB WYSŁANIA ZAKODOWANEJ WIADOMOŚCI ................................................16 

RYSUNEK 20 WYBÓR KLUCZY PUBLICZNYCH ADRESATÓW POCZTY..........................................17 

RYSUNEK 21 OKNO DO WPISANIA HASŁA ..................................................................................17 

RYSUNEK 22 ZASZYFROWANA WIADOMOŚĆ PO STRONIE ADRESATA.........................................18 

RYSUNEK 23 WIDOK ZASZYFROWANEJ WIADOMOŚCI W OKNIE SKRZYNKA ODBIORCZA 
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RYSUNEK 24 OKNO OUTLOOK EXPRESS DO ODSZYFROWANIA WIADOMOŚCI ............................20 
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• Start->Programy->PGP->PGPkeys oznacza, że należy kursor myszki umie-
ścić w lewym dolnym polu ekranu o napisie Start i kliknąć na nim.  Rozwinie się 
pasek menu, z którego należy ponownie kursorem myszy wybrać pole o napisie Pro-
gramy, następnie po ukazaniu się podmenu wybrać pole PGP i dalej po rozwinięciu 
się kolejnego podmenu pole PGPkeys. Ostania operacja spowoduje uruchomienie się 
programu PGPkeys. 


